BusTools/ARINC Upgrade v3.80

This file will upgrade BusTools/ARINC v2.61 or greater to version 3.80. Supports 32-bit/64-bit Windows XP/Vista/7/Server 2008 R1+R2/8/8.1/Server 2012 R1+R2/10. You must have v2.61, v2.70, v2.80, v2.90, v3.00, v3.20, 3.30, 3.40, 3.50, 3.60 or 3.70 currently installed to use this upgrade. If you have an earlier version please contact support@abaco.com for upgrade instructions.

Please Log In

The file you are trying to access requires you to be logged in as a registered user. Registration is free, sign up today.